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บทคัดย่อ 

            การปลูกส้มในจังหวัดลำปาง  พื้นท่ีอำเภอแม่พริกมีจำนวนการเพาะปลูกส้ม 640 ไร่ ผลผลิต 2,500 

กิโลกรัมต่อไร่ ผลผลิตรวม 3,110 ตัน คิดเป็นมูลค่าผลผลิต 53 ล้านบาท (กรมส่งเสริมการเกษตร,2558) จน

กลายเป็นพืชประจำท้องถิ่น ด้วยมีคุณสมบัติ เป็นพืชท่ีเหมาะสมกับสภาพท้องถิ่น มีความทนทานต่อ

สภาพแวดล้อม การปลูกดูแลรักษาง่าย จากการสำรวจและสอบถามข้อมูลจากเกษตรกรไม่พบว่ามีการใช้

สารเคมีในการป้องกันกำจัดศัตรูพืช 

         อำเภอแม่พริกนิยมปลูกกันมาก ทำให้ส้มเป็นท่ีรู้จักและนิยม ผู้ทำวิจัยเห็นได้เห็นถึงความสำคัญของ

ผลผลิตของส้มจึงทำการศึกษาเกี่ยวกับการใช้เทคนิค NDVI,SAVI และ RVI นำมาเปรียบเทียบกันว่าเทคนิคไหน

มีศักยภาพในการติดตามการเพาะปลูกส้มมากกว่ากัน โดยใช้ภาพถ่ายดาวเทียม Sentinel-2 โดยใช้ในช่วงเดือน

พฤศจิกายน ปี 2563 ถึง เดือนตุลาคม ปี 2564 ในช่วงฤดูร้อน ฤดูฝน ฤดูหนาว มาใช้เพื่อเป็นเครื่องมือในการ

ประเมินพื้นท่ีเพาะปลูกติดตามและใช้วิธีการทางสถิติในการเปรียบเทียบว่าสามารถใช้ติดตามกันเจริญเติบโต

ของส้มได้หรือไม ่
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ABSTRACT 

        Orange cultivation in Lampang Province The area of Mae Phrik District has orange 

cultivation of 640 rai, yield 2,500 kg per rai, total yield 3,110 tons, with a yield value of 53 

million baht (Department of Agricultural Extension, 2015) until becoming a local crop. with 

qualified It is a plant suitable for local conditions. It is resistant to the environment. easy 

planting and care from surveys and inquiries from farmers, no chemicals were used to prevent 

pesticides.  

        Mae Phrik District is very popular to grow. Make oranges known and popular. Recognizing 

the importance of citrus yields, the researchers investigated the use of NDVI, SAVI and RVI 

techniques to compare which techniques had potential for citrus cultivation. Sentinel-2 

satellite imagery from November 2020 to October 2021 in summer, rain and winter. It was 

used as a tool for estimating, tracking farmland and using statistical methods to compare. that 

it can be used to track the growth of oranges or not. 

 

 

 

 



 
 

 

บทที่ 1 

บทนำ 

 1.1 ที่มาและความสำคัญ 

     ส้ม เป็นผลไม้ท่ีสามารถปลูกได้ท่ัวไปในเขตร้อน และกึ่งร้อนในบริเวณท่ีมีความสูงจากน้ำทะเลปานกลาง ไม่

ต้องการความช้ืนสูงมากนัก มีการปลูกมากในภาคเหนือตอนบนของประเทศโดยจะปลูกมากท่ีจังหวัดลำปาง ใน

เขตอำเภอเถิน และอำเภอแม่พริก จนเป็นผลไม้ประจำถิ่น สำนักงานเกษตรและสหกรณ์จังหวัดลำปาง เห็นว่า 

ส้มเกล้ียงเป็นสินค้าประจำถิ่นของจังหวัดลำปางและมีโอกาสท่ีจะพัฒนาขยายผลไปยังพื้นท่ีอื่น ๆ ได้ จึงควรมี

การจัดทำแนวทางการพัฒนาสินค้ำ “ส้ม”เพื่อใช้เป็นกรอบแนวทางการขับเคล่ือนต่อไป 

    การปลูกส้มในจังหวัดลำปาง มีการปลูกกันมานานแล้วมากกว่า 100 ปี ในท้องท่ี อำเภอเถิน และขยายพื้นท่ี

ปลูกไปอำเภอแม่พริกซึ่งมีพื้นท่ีติดต่อกัน จำนวนพื้นท่ีปลูกในปัจจุบัน 1,244 ไร่ คือ พื้นท่ีอำเภอเถิน จำนวน 

604 ไร่ และพื้นท่ีอำเภอแม่พริก จำนวน 640 ไร่ ผลผลิต 2,500 กิโลกรัมต่อไร่ ผลผลิตรวม 3,110 ตัน คิดเป็น

มูลค่าผลผลิต 53 ล้านบาท (กรมส่งเสริมการเกษตร,2558) จนกลายเป็นพืชประจำท้องถิ่น ด้วยมีคุณสมบัติ เป็น

พืชท่ีเหมาะสมกับสภาพท้องถิ่น มีความทนทานต่อสภาพแวดล้อม การปลูกดูแลรักษาง่าย จากการสำรวจและ

สอบถามข้อมูลจากเกษตรกรไม่พบว่ามีการใช้สารเคมีในการป้องกันกำจัดศัตรูพืช เปน็คุณสมบัติเด่นของส้มอีก

อย่างท่ีต่อจากคุณภาพเดิม คือ เป็นส้มค้ันน้ำท่ีมีรสชาติเฉพาะตัวอร่อยกลมกล่อมไม่เหมือนส้มชนิดใดๆ อำเภอ

เถินและอำเภอแม่พริก อยู่ทางตอนใต้ของจังหวัดลำปาง สภาพพื้นท่ีเป็นป่าไม้รัง บางส่วนเป็นทุ่งหญ้า พื้นท่ี

ส่วนใหญ่เป็นท่ีราบภูเขาสูงและท่ีราบลุ่มริมฝ่ังแม่น้ำอันเป็นท่ีราบดินตะกอนเก่า ผืนดินมีความอุดมสมบูรณ์

ปานกลาง และมีแม่น้ำวงไหลผ่าน ทำให้สามารถทำการเกษตรได้ตลอดท้ังปี 

       การปลูกส้มของจังหวัดลำปาง เป็นไม้ผลท่ีเคยสร้างช่ือเพียงในช่วง 30 ปี ท่ีผ่านมา ทำให้เกษตรกรใน

อำเภอแม่พริกนิยมปลูกกันมาก ทำให้ส้มเป็นท่ีรู้จักและนิยม ผู้ทำวิจัยเห็นได้เห็นถึงความสำคัญของผลผลิตของ

ส้มจึงทำการศึกษาเกี่ยวกับการใช้เทคนิค NDVI,SAVI และ RVI นำมาเปรียบเทียบกันว่าเทคนิคไหนมีศักยภาพ

ในการติดตามการเพาะปลูกส้มมากกว่ากัน โดยใช้ภาพถ่ายดาวเทียม Sentinel-2 มาใช้เพื่อเป็นเครื่องมือในการ

ประเมินพื้นท่ีเพาะปลูกติดตามและใช้วิธีการทางสถิติในการเปรียบเทียบ 

1.2 วัตถุประสงค์  

     1.เพื่อศึกษาค่า NDVI , SAVI และ RVI ต่อการผลิตไม้ผล 
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    2.การเปรียบเทียบค่า NDVI , SAVI และ RVI จะคำนวนค่าเฉล่ีย ส่วนเบ่ียงเบนมาตรฐาน และจำนวน pixel 

ท่ีได้จากตำแหน่งแปลงเกษตรกรท่ีเข้าร่วมโครงการเกษตรแปลง ทำการเปรียบเทียบค่า ดัชนีพรรณพืชท้ัง 3 

ชนิดด้วยเทคนิคทางสถิติด้วย ANOVA โดยจะศึกษาท้ังช่วงฤดูร้อน ฤดูฝน และฤดูหนาว 

1.3 ประโยชน์ที่คาดว่าจะได้รับ 

    1.สามารถใช้ NDVI,SAVI และ RVI ติดตามการเปล่ียนแปลงการเพาะปลูกไม้ผล(ส้ม) 

    2.สามารถทราบว่าค่า NDVI,SAVI และ RVI ของไม้ผล(ส้ม)แตกต่างจากพืชชนิดอื่นอย่างชัดเจน 

1.4 คำถามวิจัย 

    -NDVI , SAVI และ RVI ท้ัง 3 ชนิดนี้สามารถใช้ติดตามการเพาะปลูกของส้มได้จริงหรือไม่ 

1.5 ขอบเขตงานวิจัย 

    พื้นท่ีศึกษาท้ังหมดของอำเภอแม่พริก จังหวัดลำปาง ศึกษาการติดตามการเปล่ียนแปลงการเพาะปลูกไม้ผล

(ส้ม)ด้วยเทคนิค NDVI SAVI และ RVI จากภาพดาวเทียม Sentinel-2 ในป ี พ.ศ.2563-2564 ช่วงเดือน

พฤศจิกายน - เดือนตุลาคม โดยจะศึกษาท้ังช่วงฤดูหนาว ฤดูร้อน ฤดูฝน ซึ่งจะทำการเปรียบเทียบถึงศักยภาพ

ในการติดตามการเปล่ียนแปลงการเพาะปลูกไม้ผล(ส้ม)ของอำเภอแม่พริก จังหวัดลำปาง 

1.6 ขอบเขตการศึกษา 

1.6.1 ขอบเขตพื้นที่การศึกษา   

   อำเภอแม่พริกตั้งอยู่ทางทิศตะวันตกเฉียงใต้ของจังหวัดลำปาง พิกัดภูมิศาสตร์: 17°26′54″N 99°6′54″E แบ่ง

พื้นท่ีการปกครองออกเป็น 4 ตำบล 30 หมู่บ้าน ได้แก่ ตำบลแม่พริก จำนวน 10 หมู่บ้าน ตำบลผาปัง จำนวน 

5 หมู่บ้าน ตำบลแม่ปุ จำนวน 6 หมู่บ้าน ตำบลพระบาทวังตวง จำนวน 8 หมู่บ้านพื้นท่ีท้ังหมด 538.921 ตร.

กม.ประชากร (2562) ท้ังหมด 16,021 คน ความหนาแน่น 29.72 คน/ตร.กม. อยู่สูงจากระดับน้ำทะเล 628.80 

เมตร มีอาณาเขตติดต่อกับเขตการปกครองข้างเคียงดังต่อไปนี ้

ทิศเหนือ ติดต่อกับอำเภอล้ี (จังหวัดลำพูน) 

ทิศตะวันออก ติดต่อกับอำเภอเถิน 

ทิศใต้ ติดต่อกับอำเภอบ้านตาก (จังหวัดตาก) 

ทิศตะวันตก ติดต่อกับอำเภอสามเงา (จังหวัดตาก) และอำเภอล้ี (จังหวัดลำพูน) 
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  ภาพที่ 1.1 แผนที่แสดงขอบเขตอำเภอแม่พริก จังหวัดลำปาง 

1.6.2 ภูมิประเทศ 

      สภาพพื้นท่ีเป็นท่ีราบเทือกเขา มีท่ีราบทำการเกษตรตามเชิงเขาและริมแม่น้ำ สภาพดินเป็นดินพื้นท่ีภูเขา 

ลักษณะป่าไม้เป็นป่าไม้รัง 

1.6.3 สภาพอากาศ  

      จากลักษณะภูมิประเทศของจังหวัดท่ีคล้ายอ่างกระทะ จึงทำให้อากาศร้อนอบอ้าวเกือบตลอดปี  ฤดูร้อน

จะร้อนจัด ปี 2563 มีอุณหภูมิสูงสุด 43.0 องศาเซลเซียส และฤดูหนาวจะหนาวจัด  มีอุณหภูมิต่ำสุด 14.30 

องศาเซลเซียส 

ลักษณะภูมิอากาศแบ่งเป็น 3 ฤดู คือ 

1.) ฤดูร้อน เริ่มประมาณต้นเดือนมีนาคมถึงเดือนพฤษภาคม 

2.) ฤดูฝน เริ่มประมาณกลางเดือนพฤษภาคมถึงเดือนพฤศจิกายน 

3.) ฤดูหนาว เริ่มประมาณเดือนพฤศจิกายนถึงเดือนกุมภาพันธ์ 
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1.7 นิยามศัพท์เฉพาะ 

     การสำรวจจากระยะไกล (Remote Sensing) หมายถึงเป็นเครื่องมือวัดไม่มีการสัมผัสกับส่ิงท่ีต้องการ

ตรวจวัดโดยตรง กระทำการสำรวจโดยให้เครื่องวัดอยู่ห่างจากส่ิงท่ีต้องการตรวจวัดข้อมูลท่ีได้จากการถ่ายภาพ

ทางเครื่องบินในระดับต่ำ ท่ีเรียกว่า รูปถ่ายทางอากาศ (Aerial Photo) และข้อมูลท่ีได้จากการบันทึกภาพจาก

ดาวเทียมในระดับสูงกว่า เรียกว่า ภาพถ่ายจากดาวเทียม (Satellite Image) การวิเคราะห์มี 2 แบบคือ 1.การ

วิเคราะห์ด้วยสายตา 2.การวิเคราะห์โดยใช้คอมพิวเตอร์ ผลจากการวิเคราะห์ไม่ว่าจะเป็นวิธีใดก็ตาม จะแสดง

ถึงลักษณะท่ีแท้จริงของพื้นท่ี หรือของบริเวณท่ีท าการศึกษา และผลจากการศึกษานี้ โดยมากจะอยู่ในลักษณะ

แผนท่ีการจำแนกประเภทการใช้ท่ีดิน หรือแผนท่ีแยกประเภททรัพยากรต่างๆ 

    ดัชนีพืชพรรณ (Vegetation Index) คือค่าท่ีบอกถึงสัดส่วนของพืชพรรณท่ีปกคลุมพื้นผิว โดยการคำนวณ

จากการนำช่วงตล่ืนท่ีเกี่ยวข้องกับพืชพรรณมาทำสัดส่วนซึ่งกันและกัน วิธีท่ีนิยมใช้งานกนัมาก เรียกว่า 

Normalized Difference Vegetation Index(NDVI) เป็นการนำค่าความแตกต่างของการสะท้อน ของพื้นผิว

ระหว่างช่วงคล่ืนใกล้อินฟาเรดกับช่วงคล่ืนท่ีตามองเห็นสีแดงมาทำสัดส่วนกับค่าผลบวกของท้ังสองช่วงคล่ืน

เพื่อปรับให้เป็นลักษณะการกาะจายแบบปกติ 

  ดัชนีพืชพรรณ (Soil-Adjusted Vegetation Index :SAVI) เป็นดัชนีพืชพรรณท่ีพยายามท่ีจะลดอิทธิพลของ

ความสว่างของดินโดยใช้ปัจจัยการแก้ไขดินบริเวณท่ีมีความสว่าง วิธีนี้มักจะใช้ในดินแดนแห้งแล้งท่ีมีปกพืช

คลุมอยู่ในระดับต่ำ 

  ดัชนีพืชพรรณ RVI (Ratio Vegetation Index) เป็นการทำสัดส่วนระหว่างช่วงคล่ืน 2ช่วงคล่ืนอย่างง่ายๆ คือ 

นำเอาช่วงคล่ืนอินฟราเรดใกล้มาหารด้วยช่วงคล่ืนตามองเห็นสีแดง ดังสมการของ Jackson and Huete 

(1991) ค่าของ RVI จะอยู่ระหว่าง 0 ถึง มากกว่า 30 ซึ่งพืชท่ีมีสุขภาพดีมักจะมีค่า RVI อยู่ระหว่าง 2 ถึง 8 
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1.8 กรอบแนวคิด 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  ภาพที่ 1.2 กรอบแนวคิด 

 

 

 

ดาวเทียม Sentinel-2 

ประมวลผลภาพ 

หาค่าดัชนีพืชพรรณ NDVI 

 

หาค่าดัชนีพืชพรรณปรับแก้หน้าดิน 

SAVI 

 

เปรียบเทียบดัชนีของ 

NDVI,SAVI และ RVI 

 

สรุปผล 

หาค่าดัชนีอัตราส่วนพืชพรรณ RVI 

 



 
 

 

บทที่ 2 

เอกสารและงานวิจัยที่เก่ียวข้อง 

     ในการศึกษาค่าดัชนีพืชพรรณขั้นสูง NDVI SAVI และ RVI ท่ีมีศักยภาพในการติดตามการเกษตรไม้ผล 

กรณีศึกษาสวนส้มในเขตอำเภอแม่พริก  จังหวัดลำปาง ในงานวิจัยครั้งนี้ได้ศึกษาค้นคว้าเอกสารและผลงานท่ี

เกี่ยวข้อง เพื่อเป็นแนวทางท่ีชัดเจนในการทำวิจัยในครั้งนี้ โดยมีรายละเอียดของประเด็นต่างๆดังนี้ 

            1.ศึกษาการเพาะปลูกและดูแลไม้ผล(ส้ม) 

            2.ทฤษฎีท่ีนำมาใช้ในการศึกษา 

            3.ดัชนีพืชพรรณ NDVI 

            4.ดัชนีพืชพรรณปรับแก้ดิน SAVI 

            5.ดัชนีอัตราส่วนพืชพรรณ RVI  

            6.งานวิจัยท่ีเกี่ยวข้อง 

2.1 ศึกษาการเพาะปลูกและดูแลไม้ผล 

2.1.1 ลักษณะประจำพันธุ์ของส้ม 

       ทรงพุ่ม ส้มสายน้ำผ้ึงมีการเจริญได้ดีพอๆ กับส้มเขียวหวาน โดยจะมีทรงพุ่มแน่นกว่าส้มเขียวหวาน 

ลักษณะกิ่งและใบจะต้ังขึ้น ในขณะท่ีส้มเขียวหวานใบจะตกหรือห้อยลงมา ใบของส้มสายน้ำผ้ึงเมื่อเทียบกับ

ส้มเขียวหวาน จะมีขนาดเล็กและมีสีเขียวเข้มมากกว่า นอกจากนี้ใบยังมีกล่ินหอมคล้ายส้มจีน และส้มพองแกน             

ผล ส้มสายน้ำผ้ึงมีลักษณะผลคล้ายส้มเขียวหวานมาก ขณะท่ีผลยังอ่อนจะมีสีคล้ายส้มเขียวหวาน เมื่อแก่จัดผิว

จะเปล่ียนเป็นสีเหลืองแดง ผกเว้นผลส้มท่ีได้จากภาคใต้จะมีสีผิวหมือนกันส้มเขียวหวาน ปอกเปลือกง่าย 

เปลือกมีกล่ินหอมคล้ายส้มจีน หรือส้มพองแกน ส้มพันธุ์นี้มีช่วงเวลาการเก็บเกี่ยว 8-8 เดือนครึ่ง ในการปลูก

จากกิ่งตอนจะเก็บเกี่ยวผลผลิตได้ในปีท่ี 3 กิ่งตอนส้มสายน้ำผ้ึง  ต้นส้มท่ีเจริญเต็มท่ี ให้ผลผลิตมากถึง 80-200 

กิโลกรัม/ต้น/ปี  แปลงปลูกส้มสายน้ำผ้ึงขนาดใหญ่ในเขตภาคเหนือ 

2.1.2 การเตรียมพื้นที่  

     พื้นท่ีดอน ให้ขุดตอไม้ออก ไถพรวนให้ลึก 30-40 เซนติเมตร ปรับพื้นท่ีให้เรียบ แล้วขึ้นแปลงเป็นรูปลอน

ลูกฟูกขวางทางแสงอาทิตย์กว้าง 3 เมตร สูง 40 เซนติเมตร ไม่จำกัดความยาว โดยให้มีพื้นท่ีว่างระหว่างแปลง  
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3 เมตร สำหรับให้เครื่องจักรเข้าทำงานได้โดยสะดวก ทำร่องน้ำ เพื่อระบายน้ำท่ีไหลออกจากแปลงลงสู่แหล่ง

น้ำธรรมชาติ  

    ถ้าเป็นพื้นท่ีลุ่ม ขุดเป็นร่องหรือยกร่อง โดยมีสันร่องซึง่จะใช้ปลูกกว้างประมาณ 6 เมตร ร่องน้ำกว้าง 1.50 

เมตร ลึก 1 เมตร ก้นร่องน้ำกว้าง 70 เซนติเมตร การยกร่องควรทำขวางแสงอาทิตย์ เพราะจะทำให้ร่องได้รับ

แสงสม่ำเสมอท่ัวถึง กรณีท่ีลุ่มมากต้องทำคันกั้นน้ำรอบสวนมีท่อระบายน้ำเข้า-ออกจากสวนได้ 

2.1.3 การจัดระยะปลูก 

          การจัดวางแนวปลูกควรทำให้เหมาะสมโดยอาจใช้ระยะปลูก 2 x 6, 3 x 6, 3 x 7 หรือ 4 x 6 และควร

จัดแถวในแนวขวางแสงอาทิตย์ เพื่อไม่ให้ต้นส้มบังแสงกัน การเลือกระยะปลูกมีความสำคัญ ระยะปลูกใกล้จะมี

ข้อดคือให้ผลผลิตมาก เช่น ในช่วงปีท่ี 3-5 การปลูกในระยะ 2 x 6 จะให้ผลผลิตในปริมาณมากกว่าการปลูกท่ี

ระยะ 4 x 6 ถึง 1 เท่าตัว แต่อาจจะเกิดปัญหาเรื่องการสะสมของโรคและแมลงเนื่องจากเบียดชิดกันของทรง 

พุ่ม 

 2.1.4 การเตรียมดิน  

          ก่อนท่ีจะลงมือปลูกส้ม ส่ิงท่ีขาดไม่ได้เลยคือการวิเคราะห์สภาพของดิน แล้วปรับปรุงดินไปตาม

คุณสมบัติของดิน เช่น การเติมอินทรีวัตถุ ปูน โคโลไมท์หรือยิปซั่ม สำหรับปริมาณท่ีใส่นั้นก็ขึ้นอยู่กับผลการ

ตรวจวิเคราะห์สภาพของดินนั่นเอง วิธีการใส่ควรใส่ในแนวของแถวปลูกท่ีกำหนดไว้โดยให้กว้างประมาณ 2 

เมตร ยาวไปตามแปลงปลูกแล้วไถกลบให้เข้ากัน แล้วทิ้งไว้ 1 ฤดูฝนก่อนปลูก ตัวอย่างดินท่ีเก็บมาวิเคราะห์

สามารถส่งไปตรวจได้ท่ี สำนักวิจัยและพัฒนาการเกษตร (สวพ.) ท้ัง 8 เขต  

 

 

 

 

 

 

ภาพที่ 2.1 การเตรียมเพื่อเพาะปลูกส้ม 
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2.1.5 การเลือกต้นพันธุ ์

          การปลูกต้นส้มในปัจจุบันนิยมใช้ 2 วิธีคือ การปลูกจากกิ่งตอนและใช้วิธีการติดตากับต้นตอ การปลูก

จากกิ่งตอน อาจทำให้เกิดปัญหาเรื่องโรคท่ีติดมากับต้นพันธุ์ ต้นโทรม อายุส้ัน ผลร่วง ผลด้อยคุณภาพ ดังนั้นใน

การเลือกต้นพันธุ์ ควรใช้ความพิถีพิถันในการเลือกโดยซื้อต้นพันธุ์จากแหล่งท่ีเช่ือถือได้ 

2.1.6 ขั้นตอนการปลูก 

     1. วัดระยะปลูกและกำหนดจุดปลูก โดยแถวปลูกควรอยู่บริเวณกึ่งกลางแปลงแต่ละแปลง  

     2. ขุดหลุมขนาด 50 x 50 x 50 เซนติเมตร ผสมปุ๋ยหมักหรือปุ๋ยคอกกับดินท่ีขุดขึ้นมา อัตราต้นละ 10 

กิโลกรัม พร้อมกับปุ๋ยรอกฟอตเฟต 0.5 กิโลกรัม และปุ๋ยเคมีสูตรเสมอ เช่น 15-15-15 ประมาณ 10 กรัม 

     3. แหวกดินทำหลุมให้มีขนาดโดกว่าถุงหรือกระถางท่ีเล้ียงต้นพันธุ์ 

     4. ฉีกถุงออก โดยก่อนฉีกถุงให้ใช้มือบีบดินในถุงให้แยกออกจากกัน  

     5. เขย่าวัสดุปลูกท่ีติดอยู่กับรากออกให้หมด ใช้กรรไกรตัดรากแก้วส่วนท่ีขดงอออก พร้อมท้ังตัดส่วนยอด

และใบออกบ้าง เพื่อให้เกิดการสมดุลกับรากท่ีเหลือ 

      6. วางต้นพันธุ์ลงในหลุม จัดรากฝอยท่ีมีอยู่เป็นชั้นๆ แล้วแผ่รากในแต่ละช้ันออกรอบข้าง  

      7. ใช้ดินกลบรากไล่ขึ้นมาเป็นชั้น โดยให้รากฝอยช้ันบนสุดอยู่ต่ำกว่าระดับดินบนประมาณ 1 เซนติเมตร 

      8. ใช้ดินผสมปุ๋ยหมักอัตราส่วน 1:1 กลบโคนเป็นรูปกระทะคว่ำกว้างประมาณ 1 เมตร และสูงประมาณ 

20 เซนติเมตร 

      9. ผูกต้นติดกับหลักป้องกันการโยกคลอนแล้วรดน้ำให้ชุ่ม 

2.1.7 การให้น้ำ 

การให้น้ำในสวนส้มมีหลักการดังนี้ 

    1. ควรให้น้ำทันทีประมาณ 5-10 แกลลอน เมื่อปลูกเสร็จ และให้น้ำอีกครั้งภายใน 2-3 วันหลังจากครั้งแรก 

    2. หลังจากนั้นให้น้ำทุกๆ 2-5 วัน จนกว่าส้มจะต้ังตัวได้ ข้อสำคัญอย่าปล่อยให้ต้นส้มอดน้ำจนต้นเฉา 

    3. วิธีการให้น้ำ อาจใช้สายยางระบบน้ำหยด มินิสปริเกอร์ หรือเรือพ่นน้ำ หรือบิ๊กกัน ตามความเหมาะสม 
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ภาพที่ 2.2 การให้น้ำต้นส้ม 

 

2.1.8 การเก็บเก่ียว 

           เมื่อผลส้มอายุประมาณ10เดือนหลังจากออกดอกก็สามารถเก็บเกี่ยวผลผลิตได้โดยใช้มือจับบริเวณ

ด้านใต้ผลส้มข้ึนไป แล้วหักพับให้ตรงส่วนขั้วผลไปด้านใดด้านหนึ่ง ผลส้มก็จะหลุดออกได้โดยง่าย 

         ภายหลังจากส้มเขียวหวานติดผลแล้ว ควรปฏิบัติดังนี้ 

          1. ปลิดผลออกบ้าง ในกิ่งท่ีติดผลมากๆ 

          2. ตัดแต่งผลท่ีเป็นโรคออกแล้วนำไปฝังกลบหรือเผาเสีย 

          3. ค้ำยันกิ่ง เพื่อป้องกันกิ่งฉีกหักเนื่องจากการรับน้ำหนัก หรือลมแรง 

 2.1.9 สุขลักษณะและความสะอาด 

          ควรรักษาแปลงปลูกให้ถูกสุขลักษณะและสะอาดอยู่เสมอ 

          1. กำจัดวัชพืช ควรกำจัดขณะวัชพืชยังเล็ก เพื่อไม่ให้แข่งขันกับพืชหลัก หรือเป็นแหล่งเพาะศัตรูพืช 

หรือติดไปกับผลผลิต 

          2. ควรเก็บวัชพืช เศษพืชโดยเฉพาะท่ีเป็นโรคไปทำลายนอกแปลงปลูก  
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          3. อุปกรณ์ เช่น กรรไกร เครื่องพ่นสารเคมี ภาชนะท่ีใช้เก็บผลผลิต ฯลฯ หลังจากใช้งานแล้วต้องทำ

ความสะอาด และเก็บให้อยู่ในสภาพพร้อมใช้งานอยู่เสมอ 

          4. ภาชนะบรรจุสารเคมีท่ีใช้หมดแล้ว ให้ล้างทำความสะอาด นำน้ำท่ีล้างไปพ่นป้องกันกำจัดศัตรูพืช 

สำหรับภาชนะบรรจุให้ทำลายอย่างเหมาะสม เช่น ฝังดิน ไม่ควรนำกลับมาใช้อีก 

 

 

 

 

 

 

ภาพที่ 2.3 โรคแคงเกอร์ในพืชตระกูลส้ม 

2.2 การสำรวจระยะไกล (Remote Sensing) 

      เป็นการสำรวจจากระยะไกลโดยท่ีเครื่องมือวัดไม่มีการสัมผัสกับส่ิงท่ีต้องการตรวจวัดโดยตรง สำรวจโดย

ให้เครื่องวัดอยู่ห่างจากส่ิงท่ีต้องการตรวจวัด อาจติดต้ังเครื่องวัด เช่น กล้องถ่ายภาพ ไว้ยังท่ีสูง บนบอลลูน บน

เครื่องบิน แล้วอาศัยคล่ืนแม่เหล็กไฟฟ้าท่ีแผ่ หรือสะท้อนมาจากส่ิงท่ีต้องการสำรวจเป็นส่ือในการวัด การ

สำรวจโดยใช้วิธีนี้จะสามารถเก็บข้อมูลได้เป็นจำนวนมาก ในบริเวณท่ีกว้างกว่าการสำรวจภาคสนาม และไม่

จำเป็นท่ีต้องสัมผัสกับวัตถุตัวอย่าง เช่น เครื่องบินสำรวจเพื่อถ่ายภาพในระยะไกล การใช้ดาวเทียมสำรวจ

ทรัพยากรทำการเก็บข้อมูลพื้นผิวโลกในระยะไกล 

2.2.1 หลักการทำงานของดาวเทียมสำรวจทรัพยากร 

     การสำรวจข้อมูลทรัพยากรจากระยะไกล ทำได้โดยอาศัยพลังงานแม่เหล็กไฟฟ้า ซึ่งมีอยู่ท่ัวไปใน

บรรยากาศรอบตัวเรา สำหรับเป็นพาหะในการส่ือข่าวสารเกี่ยวกับทรัพยากรต่างๆ รวมทั้งทรัพยากรการเกษตร 

ท่ีเราสนใจด้วย วัตถุทุกอย่างในโลกมีคุณสมบัติทางแม่เหล็กไฟฟ้าต่างกัน เมื่อนำเครื่องมือบันทึก 
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ข้อมูลขึ้นไปกับ ดาวเทียม เครื่องมือนั้นจะทำการบันทึกข้อมูล ซึ่งบอกถึงลักษณะต่างๆ ของวัตถุหรือเหตุการณ์

ต่างๆ ได้ ข้อมูลเบื้องต้นท่ีได้มาอาจอยู่ในลักษณะตัวเลข ซึ่งบันทึกไว้ในจานแม่เหล็กหรือในรูปของภาพถ่าย 

2.2.2 ดาวเทียม Sentinel –2(Sentinel-2)  

     ประกอบด้วย ดาวเทียม Sentinel-2A และดาวเทียม Sentinel-2B เป็นดาวเทียมท่ีบันทึกข้อมูลค่าสะท้อน

ของดวงอาทิตย์ท่ีสะท้อนจากพื้นผิวโลกซึ่งมีความละเอียดเชิงพื้นท่ีต้ังแต่10 เมตร ถึง 60 เมตรคุณลักษณะของ

ดาวเทียม Sentinel-2 

 

 

 

 

 

 

     

 ท่ีมา (https://medium.com/geo-datascience/download-sentinel-2-high-resolution-optical-images-with-python-

2581c6fecd0e) 

2.3 วิเคราะห์ดัชนีผลต่างพืชพรรณ (Normalized Difference Vegetation Index: NDVI) 

     NDVI เป็นดัชนีท่ีคิดค้นขึ้นโดยรูสและคณะ (Jensen, 2000: 361) เป็นการทำสัดส่วนระหว่างช่วงคล่ืน 2 

ช่วงคล่ืนท่ีปรับให้มีลักษณะเป็นการกระจายปกติ คือ น้าช่วงคล่ืนอินฟราเรดใกล้มาลบด้วยช่วงคล่ืนตามองเห็น

สีแดง แล้วหารด้วยผลบวกของช่วงคล่ืนอินฟราเรดใกล้และช่วงคล่ืนตามองเห็นสีแดง (สำนักงานพัฒนา

เทคโนโลยีอวกาศและภูมิสารสนเทศ(องค์การมหาชน), 2552: 89) สมการดังนี้ 

NDVI = (NIR - RED) / (NIR + RED) 

      โดยท่ี               NDVI คือ ดัชนีพืชพรรณโดยวิธี Normalized Difference Vegetation Index 

                            NIR คือ การสะท้อนในช่วงคล่ืนใกล้อินฟราเรด 

                            RED คือ การสะท้อนในช่วงคล่ืนท่ีตามองเห็นแสงสีแดง 

https://medium.com/geo-datascience/download-sentinel-2-high-resolution-optical-images-with-python-2581c6fecd0e
https://medium.com/geo-datascience/download-sentinel-2-high-resolution-optical-images-with-python-2581c6fecd0e
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2.4 ดัชนีพืชพรรณปรับแก้หน้าดิน (Soil-Adjusted Vegetation Index :SAVI) 

    เป็นดัชนีพืชพรรณท่ีสร้างขึ้นเพื่อการคำนวณพืชพรรณในพื้นท่ีศึกษาท่ีมีปริมาณพืชพรรณค่อนข้างต่ำ มีสูตร

การคำนวณคล้ายๆ กับ NDVI แต่มีการให้ค่าคงท่ี (L) เพิ่มขึน้เพื่อลดอิทธิพลของค่าการสะท้อนจากดินท่ีเป็นพื้น

ล่างของพืชพรรณ สมการดังนี้ 

SAVI = (1+L) × (NIR – Red)/ NIR + Red + L 

     โดยท่ี         NIR คือ ค่าสะท้อนพลังงานในช่วงคล่ืนอินฟราเรดใกล้ 

                    RED คือ ค่าสะท้อนพลังงานในช่วงคล่ืนสีแดง 

                    L คือ ค่าการปกคลุมของพืช 

2.5  ดัชนีอัตราส่วนพืชพรรณ RVI (Ratio Vegetation Index) 

     ดัชนีพืชพรรณอย่างง่ายท่ีคิดค้นโดย จอร์แดน เป็นการท้าสัดส่วนระหว่างสองช่วงคล่ืนอย่างงา่ย ๆ คือ 

นำเอาช่วงคล่ืนอินฟราเรดใกล้มาหารด้วยช่วงคล่ืนตามองเห็นสีแดง มีสมการดังนี้ 

                                     RVI = NIR / RED 

      โดยท่ี            RVI = ดัชนีพืชพรรณ 

                        NIR = ช่วงคล่ืนอินฟราเรดใกล้ 

                        RED = ช่วงคล่ืนตามองเห็นสีแดง 

 

2.6 งานวิจัยที่เก่ียวข้อง 

Sadia Alam Shammi , Qingmin Meng (2021) งานวิจัยเรื่อง Use time series NDVI and EVI to develop 

dynamic crop growth metrics for yield modeling ดัชนีความแตกต่างของพืชพรรณ (NDVI) และดัชนีพืช

พรรณท่ีปรับปรุงแล้ว (EVI) ท่ีได้จากระดับปานกลางภาพดาวเทียม Resolution Imaging 

Spectroradiometer (MODIS) ถูกนำมาใช้กันอย่างแพร่หลายสำหรับการวิเคราะห์ผลผลิตพืชผลอย่างไรก็ตาม 

ตัวชี้วัดการเติบโตท่ีได้มาจาก MODIS NDVI หรือ EVI ยังไมไ่ด้มีการสำรวจและนำไปใช้กับผลผลิตยัง. เพื่อเป็น

ความรู้ท่ีดีท่ีสุดของเรา การศึกษานี้จึงเป็นครั้งแรกที่ออกแบบการเจริญเติบโตของพืชตาม NDVI และ  

 



 
 

 

13 

EVI ตัวชี้วัด ซึ่งไบโอเมตริกซ์จับสถานะและแนวโน้มของการเติบโตของพืชผล ดังนั้นจึงอาจมีประสิทธิภาพมาก

ขึ้นสำหรับการจัดการผลผลิตการเจริญเติบโต เราพัฒนาตัวชี้วัดการเจริญเติบโตตาม NDVI- และ EVI 19 ตัว

ตามลำดับ เพื่อติดตามการเก็บเกี่ยวการเจริญเติบโตและผลผลิตซึ่งอิงตามอนุกรมเวลาของผลิตภัณฑ์ข้อมูล 

MODIS Terra 16 วัน 250 ม. จากปี 2000 ถึงปี 2018 ในบรรดาตัวชี้วัดการเจริญเติบโตของพืชตาม NDVI และ 

EVI (VGM) ค่าสูงสุด (VGMmax) การบูรณาการ (VGMinteg), ผลรวมของสีเขียว (VGMsumgrn), ระยะการ

เติบโต 70 วัน (VGM70), ระยะการเติบโต 85 วัน (VGM85) และระยะการเติบโต 98 วัน (VGM98) ผลรวมของ

ระยะการเติบโต 85 วัน (VGM85รวมทั้งหมด) และผลรวมของ98 ระยะการเจริญเติบโตของวัน (VGM98total) 

เป็นท่ีกล่าวถึง ในการศึกษานี้ เราได้นำตัวชี้วัดการเจริญเติบโตของพืชเหล่านี้มาใช้สำหรับ 

แบบจำลองผลผลิตถั่วเหลืองท่ีสามเหล่ียมปากแม่น้ำมิสซิสซิปป้ี รัฐมิสซิสซิปป้ี สหรัฐอเมริกา ถั่วเหลืองเป็นพืช

หลักท่ีปลูกในท่ีนี้ภูมิภาคท่ีประกอบด้วยทั้งหมด 18 มณฑลท่ีมีรูปแบบการปลูกพืชทางการเกษตรท่ีคล้ายคลึง

กัน เราสังเกตว่า NDVI- และ EVI-based VGMmax, VGM70,VGM85, VGM98 รุ่นท่ีติดต้ังท้ังหมดท่ีดีท่ีสุดกับ 

R-Square ประมาณ 0.95 เราพบ VGM85 ท่ีใช้ NDVI โดยใช้การตรวจสอบความถูกต้องข้ามของรถไฟ 80% 

และขนาดทดสอบ 20% (เช่น ค่าเฉล่ียปกติข้อผิดพลาดในการทำนาย (NMPE) = 0.034) และ VGMmax ท่ีใช้ 

EVI (NMPE = 0.033) เป็นแบบจำลองผลตอบแทนเชิงเส้นท่ีเหมาะสมท่ีสุดสำหรับภูมิภาคนี้ การออกแบบดัชนี

การเติบโตของพืชผลแบบใหม่โดยพิจารณาจากลักษณะทางฟีโนโลยีและระบบนิเวศของพืชการศึกษานี้เพิ่มเติม

แสดงให้เห็นตัวชี้วัดการเจริญเติบโตตาม NDVI และ EVI สำหรับการติดตามการเจริญเติบโตของพืชผลและการ

สร้างแบบจำลองผลผลิตตัวชี้วัดการเติบโตเหล่านี้สามารถนำไปใช้กับการตรวจสอบพืชผลประเภทอื่นในเขต

ภูมิอากาศท่ีแตกต่างกัน 

สมสิริ สวัสด์ิเฉลิม (2550) งานวิจัยเรื่องการประมาณผลผลิตต่อไรของชาวนาปรัง จากการสะท้อนพลังงาน 

กรณีศึกษาจังหวัดสุพรรณบุรี การศึกษาการประมาณผลผลิตต่อไร่ของข้าวนาปรังจากการสะท้อนพลังงานใน

พื้นท่ีจังหวัดสุพรรณบุรีโดยเก็บข้อมูลในวันหลังจากเริ่มเพาะปลูก 30 วัน, 60 วัน, 90 วัน และ 120 วัน เพื่อนํา

ค่าการสะท้อนพลังงานท่ีได้มาหาค่าดัชนีพืชพรรณ ได้แก่ RVI NDVI IPVI และ SAVI และนําไปศึกษา

ความสัมพันธ์ของผลผลิตต่อไร่ ดัชนีพื้นท่ีใบและมวลชีวภาพเพื่อสร้างสมการประมาณผลผลิตข้าวนาปรัง ซึ่ง

ดัชนีพืชพรรณได้จากการตรวจวัดค่าการสะท้อนพลังงาน ด้วยเครื่องสเปคโตรมิเตอร์ (Spectrometer) ดัชนี

พื้นท่ีใบได้จากการวัดพื้นท่ีใบข้าวด้วยเครื่องมือวัดพื้นท่ีมวลชีวภาพได้จากการช่ังน้ำหนักต้นข้าวส่วนท่ีอยู่เหนือ

พื้นดินซึง่นําไปอบท่ี อุณหภูมิ 80 องศาเซลเซียส เป็นเวลา 72 ช่ัวโมง ผลผลิตต่อไร่ได้จากการช่ังน้ำหนักข้าวที่

ความช้ืน14เปอร์เซ็นต์จากนั้นนำค่าดัชนีพืชพรรณดัชนีพื้นท่ีใบมวลชีวภาพและผลผลิตต่อไร่มาหาค่า

สัมประสิทธิ์สหสัมพันธ์แบบเพียร์สันและนําไปสร้างสมการการประมาณผลผลิตข้าวนาปรังโดยสร้างสมการ 
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ถดถอยด้วยวิธี stepwise ผลการศึกษาพบว่าค่าสัมประสิทธิ์สหสัมพันธ์ระหว่างปริมาณผลผลิตกับดัชนีพื้นท่ีใบ 

และปริมาณผลผลิตกับมวลชีวภาพมีความสัมพันธ์กันนสูงมากและเป็นไปในทางเดียวกันส่วนค่าสัมประสิทธิ์

สหสัมพันธ์ระหว่างดัชนีพืชพรรณทุกดัชนีกับดัชนีพื้นท่ีใบมีความสัมพันธ์กันสูงและเป็นไปในทางเดียวกัน ค่า

ประสิทธิ์พันธ์ระหว่างดัชนีพืชพรรณทุกดัชนีกับมวลชีวภาพมีความสัมพันธ์กันน้อยค่าสัมประสิทธิ์ระหว่างดัชนี

พืชพรรณบางดัชนีกับมวลชีวภาพมีความสัมพันธ์เป็นไปในทางเดียวกัน เมื่อนําปริมาณผลผลิตกับดัชนีพื้นท่ีใบ 

มวลชีวภาพ RVI NDVI IPVI และ SAVI ในวันหลังจากเริ่มเพาะปลูก 60 วัน มาใช้ในการสร้างสมการเนื่องจากมี

ค่าสัมประสิทธิ์ความสัมพันธ์กันสูงสุด โดยการประมาณผลผลิตต่อไร่ของข้าวนาปรัง  

ภานุพันธุ์ ไมตรี (2561) งานวิจัยเรื่อง การประยุกต์ใช้ดัชนีพืชพรรณ(NDVI)ในการศึกษาศักยภาพการเพาะปลูก

ข้าวในพื้นท่ีอำเภอเชียงของ จังหวัดเชียงราย ข้าวมีความสำคัญกับประเทศไทยเป็นอย่างมาก ซึ่งในปัจจุบัน

ประเทศไทยปลูกและส่งออกข้าวไปยังต่างประเทศเป็นอันดับ1ของโลก เนื่องจากข้าวเป็นสินค้าส่งออกและ

ตลาดโลกมีความต้องการผลผลิตข้าวที่มากขึ้นและเพื่อให้ประเทศไทยมีผลผลิตและส่งออกข้าวท่ีมากขึ้นจึงได้

ทำการศึกษาผลผลิตของข้าวในพื้นท่ีอำเภอเชียงของพื้นท่ีอำเภอเชียงของ จังหวัดเชียงราย ประชาชนในพื้นท่ี

ส่วนใหญ่ประกอบอาชีพเกษตรกรรมมีการเพาะปลูกข้าวในหลายพื้นท่ีและเป็นพื้นท่ีท่ีเหมาะแก่การเพาะปลูก

ข้าวและเพื่อท่ีจะศึกษาว่าอำเภอเชียงของ จังหวดัเชียงรายมีการเพาะปลูกข้าวได้มากกว่าค่าเฉล่ียของประเทศ

หรือไม่เพื่อเป็นแนวทางในการศึกษาผลผลิตและพัฒนาต่อไปในอนาคต จึงได้ทำการใช้เทคนิคดัชนีพืชพรรณ

NDVI และ ดัชนีความต่างค่าอินฟราเรด NDII มาทำวิเคราะห์การเปล่ียนแปลงและหาค่าผลผลิตต่อไร่ของ

เกษตรกร อำเภอเชียงของ จังหวัดเชียงราย ประชาชน ในพื้นท่ีส่วนใหญ่ประกอบอาชีพ เกษตรกรรมมีการ

เพาะปลูกข้าวในหลายพื้นท่ีการศึกษาในครั้งนี้ได้ ทำการศึกษาการจำแนกพื้นท่ีเพาะปลูกข้าวโดยใช้ดัชนีพืช

พรรณ (NDVI) และ ดัชนีความต่างค่า อินฟราเรด (NDII) ในการจำแนกพื้นท่ีและเปรียบหาความถูกต้องของ

เทคนิคท้ัง 2 ว่ามีประสิทธิภาพ แตกต่างกันหรือไม่ตามช่วงระยะเวลาการเจริญเติบโตแบ่งเป็น 4 ช่วงคือ ก่อน

เพาะปลูก, เริ่มเพาะปลูก, เจริญเติบโต และ เก็บเกี่ยว เพื่อนำมาเปรียบเทียบค่าทางสถิติพบว่าค่าดัชนีพืชพรรณ 

(NDVI) ของข้าว มีค่าเฉล่ีย 0.03, 0.04, 0.05 และ 0.05 ตามลำดับและ ค่าดัชนีความต่างค่าอินฟราเรด (NDII) 

ของ ข้าวมีค่าเฉล่ีย -0.03, 0, -0.01 และ -0.02 ตามลำดับจากการลงพื้นท่ีเก็บข้อมูลจากเกษตรกรท่ีเพาะปลูก 

ข้าว 20 รายพบว่ามีค่าเฉล่ียผลผลิตเท่ากับ 677.5กิโลกรัมต่อไร่ เมื่อเทียบกับผลผลิตเฉล่ียของประเทศไทยในปี

การเพาะปลูก พ.ศ.2559 พบว่าค่าเฉล่ียข้าวระดับประเทศเท่ากับ 666 กิโลกรัมต่อไร่ จาก การวิเคราะห์พบว่า

ค่าเฉล่ียผลผลิตข้าวพื้นท่ีอำเภอเชียงของ จังหวัดเชียงราย มีค่าสูงกว่าค่าผลผลิต ข้าวระดับประเทศอย่างมี

นัยสำคัญทางสถิต 

 



 
 

 

บทที่ 3 

วิธีดำเนินงานวิจัย 

งานวิจัยนี้ศึกษาค่าดัชนีพืชพรรณขั้นสูง NDVI SAVI และ RVI ท่ีมีศักยภาพในการติดตามการเกษตรไม้ผล 

กรณีศึกษาสวนส้มในเขตอำเภอแม่พริก  จังหวัดลำปาง ติดตามการเปล่ียนแปลงการเพาะปลูกไม้ผล(ส้ม)ด้วย

เทคนิค NDVI SAVI และ RVI จากภาพดาวเทียม Sentinel-2 ในปี พ.ศ.2563-2564 ช่วงเดือนพฤศจิกายน - 

เดือนตุลาคม โดยจะศึกษาท้ังช่วงฤดูหนาว ฤดูร้อน ฤดูฝน ซึ่งจะทำการเปรียบเทียบถึงศักยภาพในการติดตาม

การเปล่ียนแปลงการเพาะปลูกไม้ผล(ส้ม) มีวิธีการดำเนินงาน  4 ข้ันตอนดังนี ้

                 1. วิธีการศึกษา 

                 2. ข้อมูลและแหล่งข้อมูล 

                 3. เครื่องมือและโปรแกรมท่ีใช้ 

                 4. การวิเคราะห์ข้อมูล   

 

3.1 วิธีการศึกษา 

การวิจัยครั้งนี้ผู้วิจัยได้ใช้ข้อมูลภาพถ่ายดาวเทียมของ Sentinel-2 ในช่วงเดือนพฤศจิกายน ปี 2563 - เดือน

ตุลาคม ปี 2564 โดยแบ่งเป็น 3 ช่วงฤดูกาล ฤดูหนาว ฤดูร้อน และ ฤดูฝน ใช้เทคนิค NDVI SAVI และ RVI ใน

การจำแนกพื้นท่ีเพาะปลูกไม้ผล(ส้ม)ในแต่ละช่วงท่ีกำหนดไว้ ผลท่ีได้จากโปรแกรมนำมาวิเคราะห์ด้วยวิธีการ

ทางสถิติเพื่อทำการเปรียบเทียบกัน 

 

3.2 ข้อมูลและแหล่งข้อมูล 

1.ภาพดาวเทียม Sentinel-2 ในช่วงเดือนพฤศจิกายน ปี 2563 - เดือนตุลาคม ปี 2564 

2.ข้อมูลตำแหน่งของแปลงส้ม 
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3.3 เคร่ืองมือและโปรแกรมที่ใช้ 

โปรแกรม EarthExplorer ใช้ในการ download ภาพดาวเทียม 
โปรแกรม Arc Map ใช้ในการวิเคราะห์ข้อมูลและจัดทำแผนท่ี 
โปรแกรม Microsoft Excel ใช้ในการบันทึกค่าทางสถิติและคำนวณ 
โปรแกรม Erdas Imagine 2014 ใช้ในการประมวลผลภาพถ่าย 
โปรแกรม QGIS ใช้ในการวิเคราะห์ 
 

3.4 การวิเคราะห์ข้อมูล   

1. การเลือกโหลดภาพถ่ายดาวเทียม Sentinel-2 ในช่วง เดือนพฤศจิกายน ปี 2563 - เดือนตุลาคม ปี 2564 

2. นำภาพถ่ายดาวเทียมแต่ละช่วงเวลามารวมแบนด์กัน 

3. ตัดขอบเขตพื้นท่ีศึกษา 

4. นำข้อมูลพื้นท่ี ท่ีมีการเพาะปลูกส้มแสดงเป็นจุดตำแหน่งแปลง (Point) 

5. นำภาพถ่ายดาวเทียมมา Mosaic เพื่อท่ีจะให้ภาพถ่ายดาวเทียมต่อกัน 

6. นำภาพถ่ายดาวเทียมมาทำเป็น NDVI  SAVI และ RVI 

7. นำภาพถ่าย ortho วางใน QGIS เพื่อทำเป็น polygon ของแปลงส้ม 

8.นำ polygon ท่ีทำมาวางทับซ้อนในภาพถ่ายท่ีเป็นภาพ NDVI SAVI และ RVI (ทำท้ัง 3 ช่วงฤดู) 
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9. วิเคราะห์ค่าดัชนีพืชพรรณ NDVI  ค่าดัชนีพืชพรรณปรับแก้หน้าดิน SAVI และ ดัชนีพืชพรรณ RVI (ทำท้ัง 3 

ช่วงฤดู) 

10. เปรียบเทียบค่าดัชนีพืชพรรณ NDVI และค่าดัชนีพืชพรรณปรับแก้หน้าดิน SAVI และ ดัชนีพืชพรรณ RVI 

แตกต่างกันหรือไม่ อย่างมีนัยสำคัญทางสถิติ (ทำท้ัง 3 ช่วงฤดู) 

3.4.1 การข้ันการทำงาน 

1.ขั้นตอนการดาวน์โหลดภาพดาวเทียม  

เข้าเว็บไซต์ https://earthexplorer.usgs.gov/ จะปรากฏดังภาพให้คลิกเลือก Address/Place  ช่องถัดมา

ให้พิมพ์สถานท่ีท่ีเราต้องการ จากนั้นคลิกท่ี show  

 

 

 

 

 

 

 

 

ภาพที่ 3.1 วิธีการดาวน์โหลดภาพดาวเทียม 

  

 

ใส่ ว/ด/ป ท่ีเราต้องการดาวน์โหลดภาพใส่  

                                                                        ช่อง Data Rage คลิกท่ี Data Sets 

ภาพที่ 3.2 กำหนดวันเดือนปีที่ต้องการดาวน์โหลด 

https://earthexplorer.usgs.gov/%20จะ


 
 

 

 18         

  เลือกท่ี Sentinel > Sentinel-2 > Additional Criteria 

 

 

 

 

 

 

 

 

  ภาพที่ 3.3 เลือกดาวเทียม Sentinel-2 

 

           เลือก Cloud Cover > Less than 10% > Results  

 

 

 

 

 

 

 

 

      ภาพที่ 3.4 เลือกเปอร์เซ็นต์ของเมฆน้อยทีสุ่ด 

 



 
 

 

19 

เลือกภาพตามท่ีเราต้องการดาวน์โหลด คลิกท่ี Download Options > Download L1C Tile 

in JPEG2000 format (784.34 MiB) 

 

 

 

 

 

ภาพที่ 3.5 ดาวน์โหลดภาพดาวเทียม Sentinel-2 

2.ขั้นตอนการรวมแบนด์ (Composite Band) 

       เปิดโปรแกรม ERDAS IMAGINE 2014 

  

 

ภาพที่ 3.6 โปรแกรม ERDAS IMAGINE 2014 

 คลิก Spectral เลือก Layer Stack 

คลิกเลือกภาพถ่ายดาวเทียมแต่ละแบนด์เข้ามา > OK 

 

 

 

 

 

ภาพที่ 3.7 นำภาพดาวเทียม Sentinel-2 เข้าโปรแกรม 
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3.ขั้นตอนการตัดขอบเขตพื้นที่การศึกษา 

เปิดภาพถ่ายดาวเทียมท่ีทำการรวมแบนด์ไว้แล้ว 

 

 

 

 

 

 

 

 

ภาพที่ 3.8 ภาพรวมแบนด์ 

           นำไฟล์ขอบเขตพื้นท่ีเข้ามา > OK 

 

 

 

 

 

 

 

ภาพที่ 3.9 files ขอบเขตอำเภอแม่พริก 
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เลือกท่ีเครื่องมือ Vector > Paste from Selected Object 

 คลิกท่ีไฟล์ Aoi001664 (:Aoi) > คลิกท่ีขอบเขตดังรูป 

 

 

 

 

 

 

 

ภาพที่ 3.10 เคร่ืองมือตัดขอบเขต 

 เลือกท่ีเครื่องมือ Raster > Subset & Chip > Create Subset Image 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.11 ตัดขอบเขตอำเภอแม่พริกของภาพดาวเทียมที่รวมแบนด์แล้ว 
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   เลือกท่ีเก็บ > AOI ให้เลือกเป็น Viewer > OK > OK 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.12 เลือกที่ Save ภาพที่ตัดขอบเขต 

    4.นำข้อมูลพื้นท่ี ท่ีมีการเพาะปลูกข้าวโพดเล้ียงสัตว์แสดงเป็นจุดตำแหน่งแปลง (Point) 

      เปิดโปรแกรม Microsoft Excel  

        

 

ภาพที่ 3.13 โปรแกรม Microsoft Excel 2016 

นำข้อมูลพื้นท่ีเพาะปลูกส้มของเกษตรกรอำเภอแม่พริก จังหวัดลำปาง 
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ภาพที่ 3.14 ตำแหน่งการเพาะปลูกส้มของอำเภอแม่พริก 

 เปิดโปรแกรม Arc Map 10.4.1 

 

 

ภาพที่ 3.15 โปรแกรม ArcMap 10.4.1 

          คลิกท่ี File > Add Data > Add XY Data… 

คลิกท่ี ไฟล์ Excel ท่ีได้ Save > Add > OK 

 

 

 

 

 

ภาพที่ 3.16 นำพิกัดในโปรแกรม Excel เข้า Arc Map 

  5.นำภาพถ่ายดาวเทียมมา Mosaic เพื่อท่ีจะให้ภาพถ่ายดาวเทียมต่อกัน *กรณีท่ีภาพถ่าย

ดาวเทียมไม่ครอบคลุมพื้นท่ีศึกษา 

คลิกท่ี Raster > Mosaic > MosaicPro 
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คลิกท่ีเครื่องมือ Display Add Images Dialog 

 

 

 

 

 

ภาพที่ 3.17 การ MosaicPro ทำให้ภาพต่อกัน 

เลือกภาพดาวเทียมท่ีได้ทำการรวมแบนด์แล้ว > OK 

 คลิกเครื่องหมายถูกท่ีช่อง Vis 

 คลิกท่ีเครื่องมือ Dispay raster images 

 

 

 

 

 

คลิกท่ีเครื่องมือ Process > Run Mosaic 

ภาพที่ 3.18 การนำภาพเข้า 

 

 

 

ภาพที่ 3.19 เคร่ืองมือการต่อภาพ 
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เลือกท่ีบันทึก > Save 

 

 

 

 

 

ภาพที่ 3.20 เลือกพื้นที่ Save 

6.ขั้นตอนการทำภาพเป็น NDVI SAVI และ RVI โดยจะทำท้ัง 3 ฤดูกาล ฤดูหนาว ฤดูร้อน ฤดูฝน 

         จะเริ่มทำภาพเป็น NDVI SAVI และ RVI โดยจะทำในช่วงฤดูหนาว ในเดือนพฤศจิกายน ปี 2563 

         คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น NDVI เลือกแบนด์ท่ีใช้ในการทำภาพ NDVI ดังภาพ 

แล้วคลิก OK 

 

  

 

 

 

 

 

 

ภาพที่ 3.21 ขั้นตอนการทำภาพ NDVI 
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ภาพที่ 3.22 ภาพ NDVI ฤดูหนาว 

คลิก Raster > Unsupervised > NDVI     

ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น SAVI เลือกแบนด์ท่ีใช้ในการทำภาพ SAVI ดังภาพ 

แล้วคลิก OK 

 

 

 

 

 

 

 

 

ภาพที่ 3.23 ข้ันตอนการทำภาพ SAVI 
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ภาพที่ 3.24 ภาพ SAVI ฤดูหนาว 

คลิก Raster > Unsupervised > NDVI     

ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น RVI เลือกแบนด์ท่ีใช้ในการทำภาพ RVI ดังภาพ 

แล้วคลิก OK 

 

 

 

 

 

 

 

 

ภาพที่ 3.25 ขั้นตอนการทำภาพ RVI 

 



 
 

 

28 

 

 

 

 

 

 

 

 

ภาพที่ 3.26 ภาพ RVI ฤดูหนาว 

        จะเริ่มทำภาพเป็น NDVI SAVI และ RVI โดยจะทำในช่วงฤดูร้อน ในเดือนเมษายน ปี 2564 

         คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น NDVI เลือกแบนด์ท่ีใช้ในการทำภาพ NDVI ดังภาพแล้ว

คลิก OK 

        

 

 

 

 

 

 

 

ภาพที่ 3.27 ขั้นตอนการทำภาพ NDVI 
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ภาพที่ 3.28 ภาพ NDVI ฤดูร้อน 

          คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น SAVI เลือกแบนด์ท่ีใช้ในการทำภาพ SAVI ดังภาพแล้ว

คลิก OK 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.29 ขั้นตอนการทำภาพ SAVI 
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ภาพที่ 3.30 ภาพ SAVI ฤดูร้อน 

         คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น RVI เลือกแบนดท่ี์ใช้ในการทำภาพ RVI ดังภาพแล้วคลิก 

OK 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.31 ขั้นตอนการทำภาพ RVI 
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ภาพที่ 3.32 ภาพ RVI ฤดูร้อน 

จะเริ่มทำภาพเป็น NDVI SAVI และ RVI โดยจะทำในช่วงฤดูฝน ในเดือนมิถุนายน ปี 2564 

         คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น NDVI เลือกแบนด์ท่ีใช้ในการทำภาพ NDVI ดังภาพแล้ว

คลิก OK 

  

 

 

 

 

 

 

 

ภาพที่ 3.33 ขั้นตอนการทำภาพ NDVI 
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ภาพที่ 3.34 ภาพ NDVI ฤดูฝน 

        คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น SAVI เลือกแบนด์ท่ีใช้ในการทำภาพ SAVI ดังภาพแล้ว

คลิก OK 

 

 

  

 

 

 

 

 

ภาพที่ 3.35 ขั้นตอนการทำภาพ SAVI 
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ภาพที่ 3.36 ภาพ SAVI ฤดูฝน 

 

คลิก Raster > Unsupervised > NDVI 

         ต้ังช่ือ Output แล้วเลือกช่อง Index ให้เป็น RVI เลือกแบนด์ท่ีใช้ในการทำภาพ RVI ดังภาพแล้วคลิก 

OK 

  

  

 

 

 

 

 

 

ภาพที่ 3.37 ขั้นตอนการทำภาพ RVI 

 



 
 

 

34 

 

 

 

 

 

 

 

ภาพที่ 3.38 ภาพ RVI ฤดูฝน 

 

คลิกท่ีเครื่องมือ Drawing > Polygon  

เลือกไฟล์ point เข้ามา  

จากนั้นให้ทำการการดิจิไทซ์แปลง 

 

 

 

 

 

 

 

ภาพที่ 3.39 ขั้นตอนการดิจิไทซ์ 
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ขั้นตอนการวิเคราะห์ค่าดัชนีพืชพรรณ NDVI  ค่าดัชนีปรับแก้ดิน SAVI และค่าดัชนี RVI 

 เปิดภาพท่ีเป็น NDVI ขึ้นมา 

 คลิกท่ีเครื่องมือ Raster > Supervised > Signature Editor 

 

 

 

 

 

 

ภาพที่ 3.40 การประมวลผล NDVI 

 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.41 จุดที่ทำการดิจิไทซ์ NDVI  ในฤดูหนาว 

เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ NDVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 

- ค่าทางสถิติของ NDVI  ในฤดูหนาว  
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ภาพที่ 3.42 ค่าที่คำนวณ NDVI ในฤดูหนาว 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.43 จุดที่ทำการดิจิไทซ์ SAVI ในฤดูหนาว 

เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ SAVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 

- ค่าทางสถิติของ SAVI  ในฤดูหนาว 
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ภาพที่ 3.44 ค่าที่คำนวณ SAVI ในฤดูหนาว 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.45 จุดที่ทำการดิจิไทซ์ RVI ในฤดูหนาว 

เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ RVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 
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- ค่าทางสถิติของ RVI  ในฤดูหนาว 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.46 ค่าที่คำนวณ RVI ในฤดูหนาว 

 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.47 จุดที่ทำการดิจิไทซ์ NDVI ในฤดูร้อน 

เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ NDVI ดังรูป 
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- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 

- ค่าทางสถิติของ NDVI  ในฤดูร้อน 

 

 

 

 

 

 

 

 

ภาพที่ 3.48 ค่าที่คำนวณ NDVI ในฤดูร้อน 

 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.49 จุดที่ทำการดิจิไทซ์ SAVI ในฤดูร้อน 

เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ SAVI ดังรูป 
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- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 

- ค่าทางสถิติของ SAVI  ในฤดูร้อน 

 

 

 

 

 

 

 

 

                                       ภาพที่ 3.50 ค่าที่คำนวณ SAVI ในฤดูร้อน 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.51 จุดที่ทำการดิจิไทซ์ RVI ในฤดูร้อน 

เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ RVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 
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- ค่าทางสถิติของ RVI ในฤดูร้อน 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.52 ค่าที่คำนวณ RVI ในฤดูร้อน 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.53 จุดที่ทำการดิจิไทซ์ NDVI ในฤดูฝน 

  เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ NDVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 
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- ค่าทางสถิติของ NDVI  ในฤดูฝน 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.54 ค่าที่คำนวณ NDVI ในฤดูฝน 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

           Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

ภาพที่ 3.55 จุดที่ทำการดิจิไทซ์ SAVI ในฤดูฝน 

  เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ SAVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 

- ค่าทางสถิติของ SAVI  ในฤดูฝน 
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ภาพที่ 3.56 ค่าที่คำนวณ SAVI ในฤดูฝน 

 

ให้คลิกท่ีจุด ท่ีได้ทำการดิจิไทซ์ไว้ แล้วไปท่ีเครื่องมือ Create New Signature (s) From AOI 

Add จุดท่ีเราได้ทำการดิจิไทซ์แปลงเพาะปลูกข้าวโพดเข้าให้ครบท้ัง 30 จุด 

 

 

 

 

ภาพที่ 3.57 จุดที่ทำการดิจิไทซ์ RVI ในฤดูฝน 
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เลือกทุกจุด แล้วไปท่ีเครื่องมือ Merge Selected Signature เพื่อรวมให้เป็นจุดเดียวกัน 

- จะได้ค่าทางสถิติของ RVI ดังรูป 

- ให้ทำแบบนี้จนครบ ทำท้ังของ NDVI SAVI และ RVI ครบ 3 ฤดูกาล 

- ค่าทางสถิติของ RVI  ในฤดูฝน 

 

 

 

 

 

 

 

 

 

ภาพที่ 3.58 ค่าที่คำนวณ RVI ในฤดูฝน 

 

 

 

 

 

 

 



 
 

 

บทที่ 4 

ผลวิจัย 

          ศึกษาค่าดัชนีพืชพรรณขั้นสูง NDVI SAVI และ RVI ท่ีมีศักยภาพในการติดตามการเกษตรไม้ผล 

กรณีศึกษาสวนส้มในเขตอำเภอแม่พริก จังหวัดลำปาง   ผู้วิจัยได้กำหนดแบ่งผลการวิเคราะห์ออกเป็น 2 

รูปแบบ คือ 1.สรุปค่าดัชนีพืชพรรณ NDVI SAVI และ RVI  2.เปรียบเทียบค่าดัชนีพืชพรรณ NDVI SAVI และ 

RVI ในแต่ละฤดูกาลค่าดัชนีพรรณพืชต่างกันหรือไม่ โดยใช้การคำนวณทางสถิติด้วยวิธี ANOVA : Two-Factor 

Without Replication   3.เปรียบเทียบค่าดัชนีพืชพรรณ NDVI SAVI และ RVI ว่าแตกตา่งกันหรือไม่ โดยใช้

การคำนวณทางสถิติด้วยวิธี ANOVA : Two-Factor Without Replication  

   4.1 สรุปค่าดัชนีพืชพรรณ NDVI SAVI และ RVI   

           ค่าดัชนีพืชพรรณ NDVI ดัชนีพืชพรรณท่ีปรับแก้ดิน SAVI และ ดัชนีอัตราส่วนพืชพรรณ RVI    โดย

ในฤดูร้อน ค่า NDVI มีค่าเฉล่ียอยู่ท่ี 0.582 , ฤดูหนาว ค่า  NDVI มีค่าเฉล่ียอยู่ท่ี 0.594 , ฤดูฝน ค่า NDVI มี

ค่าเฉล่ียอยู่ท่ี 0.712  , ในฤดูร้อน ค่าSAVI มีค่าเฉล่ียอยู่ท่ี 0.582 , ฤดูหนาว ค่า SAVI มีค่าเฉล่ียอยู่ท่ี 0.883 , 

ฤดูฝน ค่า SAVI มีค่าเฉล่ียอยู่ท่ี 0.710 ,ในฤดูร้อน ค่า RVI มีค่าเฉล่ียอยู่ท่ี 0.583,  ฤดูหนาว ค่า  RVI มีค่าเฉล่ีย

อยู่ท่ี 0.266 , ฤดูฝน ค่า RVI มีค่าเฉล่ียอยู่ท่ี 0.709  (ตารางท่ี 1) 

ตารางท่ี 4.1 ค่าดัชนีพืชพรรณ NDVI ดัชนีพืชพรรณท่ีปรับแก้ดิน SAVI และ ดัชนีอัตราส่วนพืชพรรณ RVI 

 

 

 

 

 

    4.2 เปรียบเทียบค่าดัชนีพืชพรรณ NDVI SAVI และ RVI ในแต่ละฤดูกาลค่าดัชนีพรรณพืชต่างกัน
หรือไม่ โดยใช้การคำนวณทางสถิติด้วยวิธี ANOVA : Two-Factor Without Replication 

การตั้งสมมุติฐาน 

ในแต่ละฤดูกาลค่าดัชนีพรรณพืชต่างกันหรือไม ่

1.สมมิติฐาน "ค่าดัชนีพรรณพืชขั้นสูงท้ัง 3 แบบ ในแต่ละฤดูกาลต่างกันหรือไม่" 
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             H0 : µ1 = µ2 = µ3 

             H1 : µ1 ≠ µ2 ≠ µ3 

2. กำหนดระดับนัยสำคัญ a = 0.05 

3. สถิติท่ีใช้ทดสอบ ANOVA : Two-Factor Without Replication 

4. ผลการทดสอบ (ตารางท่ี 2) 

ตารางท่ี 4.2 ค่าในแต่ละฤดูกาลของค่าดัชนีพรรณพืชต่างกันหรือไม่ โดยใช้สถิติ ANOVA : Two-Factor 

Without Replication ในการคำนวณ 

 

 

 

 

 

 

    

   สรุป ค่า p-value columns ไม่น้อยกว่า a ยอมรับ H0 ปฏิเสธ H1  

  นั่นหมายความว่าดัชนีพรรณพืชขั้นสูงท้ัง 3 แบบ ไม่แตกต่างกันในแต่ละฤดูกาลอย่างมีนัยสำคัญทางสถิติ 

4.3 เปรียบเทียบค่าดัชนพีืชพรรณ NDVI SAVI และ RVI ว่าแตกต่างกันหรือไม่ โดยใช้การคำนวณทาง

สถิติด้วยวิธี ANOVA : Two-Factor Without Replication 

การตั้งสมมุติฐาน 

ค่าดัชนีพรรณพืชท้ัง 3 ค่าแตกต่างกันหรือไม ่

1.สมมิติฐาน "ค่าดัชนีพรรณพืชขั้นสูงท้ัง 3 แบบ ต่างกันหรือไม"่ 

           H0 : µ1 = µ2 = µ3 
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H1 : µ1 ≠ µ2 ≠ µ3 

2. กำหนดระดับนัยสำคัญ a = 0.05 

3. สถิติท่ีใช้ทดสอบ ANOVA : Two-Factor Without Replication 

4. ผลการทดสอบ (ตารางท่ี 3) 

ตารางท่ี 4.3 การคำนวณโดยใช้สถิติ ANOVA : Two-Factor Without Replication ในการคำนวณค่าดัชนี

พรรณพืชท้ัง 3 ค่าแตกต่างกันหรือไม ่

 

 

 

 

 

 

 

สรุป ค่า p-value Rows ไม่น้อยกว่า a ยอมรับ H0 ปฏิเสธ H1 

นั่นหมายความว่าดัชนีพรรณพืชขั้นสูงท้ัง 3 แบบ ไม่แตกต่างกันอย่างมีนัยสำคัญทางสถิติ 

 

 

 

 

 

 



 
 

 

บทที่ 5 

สรุปผล อภิปรายผล และข้อเสนอแนะ 

สรุปผล 

            จากการศึกษาการนำค่าดัชนีพืชพรรณ NDVI ดัชนีพืชพรรณปรับแก้ดิน SAVI และ ดัชนีอัตราส่วนพืช

พรรณ RVI มาใช้ในการติดตามการเจริญเติบโตของไม้ผล(ส้ม) มาเปรียบเทียบกันโดยการคำนวณทางสถิติด้วย

วิธี ANOVA : Two-Factor Without พบว่าดัชนีพืชพรรณท้ัง 3 แบบสามารถนำมาติดตามกันเจริญเติบโตของ

ส้มได้ แต่ในสภาพมีความแห้งแล้งตามฤดูกาลซึ่งความแห้งแล้งในฤดูกาลเพาะปลูกนี้ไม่ได้ส่งผลต่อความ

สมบรูณ์ของพืชมากนัก จึงทำให้ค่าในดัชนีพืชพรรณ ท้ัง 3 แบบ มีค่าท่ีไม่แตกต่างกันอย่างมีนัยสำคัญทางสถิติ 

 

อภิปรายผล 

           ค่าดัชนีพืชพรรณ NDVI ดัชนีพืชพรรณปรับแก้ดิน SAVI และ ดัชนีอัตราส่วนพืชพรรณ RVI ในค่าดัชนี

พืชพรรณ NDVI ค่าเฉล่ีย ฤดูฝนมีค่าเฉล่ียมากกว่าในฤดูหนาวและในฤดูร้อนมีค่าน้อยท่ี ในค่าดัชนีพืชพรรณ

ปรับแก้ดิน SAVI ค่าเฉล่ีย ฤดูหนาวมีค่าเฉล่ียมากกว่าในฤดูฝนและในฤดูร้อนมีค่าน้อยและค่าในดัชนีอัตราส่วน

พืชพรรณ RVI ค่าเฉล่ีย ฤดูฝนมีค่าเฉล่ียมากว่าในฤดูร้อนและในฤดูหนาวมีค่าน้อย จากการท่ีคำนวณทางสถิติ

ด้วยวิธี ANOVA : Two-Factor Without Replication ในการคำนวณพบว่าค่า p-value columns มีค่า

เท่ากับ 0.62 ซึ่งมีค่ามากกว่าค่าระดับนัยสำคัญ 0.05 หมายความว่าดัชนีพรรณพืชขั้นสูงท้ัง 3 แบบ ไม่แตกต่าง

กันในแต่ละฤดูกาลอย่างมีนัยสำคัญทางสถิติ 

 

           จากสมมุติฐาน นำเอาดัชนีพืชพรรณ NDVI ดัชนีพืชพรรณปรับแก้หน้าดิน SAVI และดัชนีพืชพรรณ 

RVI มาเปรียบเทียบกัน โดยการคำนวณทางสถิติด้วยวิธี ANOVA : Two-Factor Without Replication ในการ

คำนวณพบว่าค่า p-value Rows มีค่าเท่ากับ 0.44 ซึ่งมีค่ามากกว่าค่าระดับนัยสำคัญ 0.05 หมายความว่าดัชนี

พืชพรรณท้ัง 3 แบบสามารถนำมาติดตามกันเจริญเติบโตของไม้ผล(ส้ม)ได้ ดัชนีพรรณพืชขั้นสูงท้ัง 3 แบบ ไม่

แตกต่างกันอย่างมีนัยสำคัญทางสถิติ   
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ข้อเสนอแนะ 

- การใช้ภาพถ่ายดาวเทียมควรคำนึงถึงช่วงเวลาท่ีอาจมีเมฆปกคลุมบนภาพถ่าย ถ้าหลีกเล่ียงไม่ได้ ควรหาภาพ

ดาวเทียมอื่นหรือศึกษาวิธีการอื่นๆ 

- การศึกษาศักยภาพการเพาะปลูกส้มในครั้งนี้ไม่ได้มีการลงพื้นท่ีเก็บข้อมูลผลผลิตของเกษตรกร  เนื่องจาก

สถานการณ์โควิด-19 จึงทำให้ลงพื้นท่ีไม่ได้และควรมีการเก็บข้อมูลผลผลิตการปลูกส้มจากเกษตรกรโดยตรง  
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